Building a PowerHA Cluster with vscsi disks
I needed to build a PowerHA cluster in the lab to test the upgrade process in isolation. This meant I did not have access to any SAN storage that could be presented via NPIV to the cluster, so I used vSCSI devices from my test VIO Servers, as these had a couple of spare SAN disks that both VIO Servers could see.
At first I did not think that you could present vSCSI devices to multiple Clients at the same time, but I was wrong, you are allowed, it works, and both by PowerHA nodes now share the same vSCSI devices in a PowerHA cluster.
First, identify the common disks between the VIO Server pair - See my blog post for this.
http://www.capacityreports.net/AIX_Blog/admin.php?ctrl=items&blog=1&p=15
Then we can map the two hdiskpower devices to the first node.
# mkvdev -vdev hdiskpower9 -vadapter vhost2 -dev pocn070-dvg1
pocn070-dvg1 Available
# mkvdev -vdev hdiskpower10 -vadapter vhost2 -dev pocn070-dvg2
pocn070-dvg2 Available
Then we do the same for the second node, but I recieve an error telling me that the backing device is already in use.
# mkvdev -vdev hdiskpower9 -vadapter vhost3 -dev pocn071-dvg1
"hdiskpower9" is already being used as a backing device. Specify the -f flag
to force this device to be used anyway.
So I used the -f flag to mkvdev to force the mapping and this worked okay.
# mkvdev -f -vdev hdiskpower9 -vadapter vhost3 -dev pocn071-dvg1
pocn071-dvg1 Available
# mkvdev -f -vdev hdiskpower10 -vadapter vhost3 -dev pocn071-dvg2
pocn071-dvg2 Available
Running cfgmgr on the two clients shows both have two new hdisk devices.
# cfgmgr -l vscsi0
# cfgmgr -l vscsi1
Verify with lspv and lspath
# lspv
hdisk2 none None
hdisk3 none None
# lspath
Enabled hdisk2 vscsi0
Enabled hdisk3 vscsi0
Enabled hdisk2 vscsi1
Enabled hdisk3 vscsi1
Add the PVIDs on the nodes.
# chdev -l hdisk2 -a pv=yes
# chdev -l hdisk3 -a pv=yes
Verify the PVIDs with lspv.
# lspv
hdisk2 00123456789f23a9 None
hdisk3 00123456789f3c9c None
Now continue with the PowerHA setup and configuration.